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T U T O R I A L 3
Welcome Application
Introduction to Visual Programming

Objec t i ves
In this tutorial, you will learn to:
■ Set the text in the Form’s title

bar.
■ Change the Form’s

background color.
■ Place a Label control on the

Form.
■ Display text in a Label

control.
■ Place a PictureBox control

on the Form.
■ Display an image in a

PictureBox control.
■ Execute an application.

Out l i ne
3.1 Test-Driving the Welcome

Application
3.2 Constructing the Welcome

Application
3.3 Objects Used in the

Welcome Application
3.4 Wrap-Up
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2 Introduction to Visual Programming Tutorial 3

MULTIPLE-CHOICE
QUESTIONS

3.1 Property determines the Form’s background color.

3.2 To save all the project’s files, select .

3.3 When the ellipsis Button to the right of the Font property value is clicked, the
is displayed.

3.4 PictureBox property contains a preview of the image displayed in the
PictureBox.

3.5 When setting the BackColor property, the tab allows you to create your
own color.

3.6 The PictureBox class has namespace .

3.7 A Label control displays the text specified by property .

3.8 In mode, the application is executing.

3.9 The command prevents programmers from accidentally altering the size and
location of the Form’s controls.

3.10 Pixels are .

Answers: 3.1) a. 3.2) c. 3.3) d. 3.4) c. 3.5) a. 3.6) a. 3.7) c. 3.8) b. 3.9) a. 3.10) a.

EXERCISES For Exercises 3.11–3.16, you’re asked to create the GUI shown in each exercise. You
use the visual programming techniques presented in this tutorial to create a variety of
GUIs. You are creating only GUIs, therefore your applications will not be fully oper-
ational. For example, the Calculator GUI in Exercise 3.11 does not behave like a cal-
culator when its Buttons are clicked. You learn how to make your applications fully
operational in later tutorials. Create each application as a separate project. If you
accidentally double click a control in Design view, the IDE displays the Form’s
source code. To return to Design view, select View > Designer.

3.11 (Calculator GUI) Create the GUI for the calculator shown in Fig. 3.35.

a) BackColor b) BackgroundColor

c) RGB d) Color

a) Save > Solution > Save Files b) File > Save
c) File > Save All d) File > Save As…

a) Font Property dialog b) New Font dialog
c) Font Settings dialog d) Font dialog

a) Picture b) ImageName

c) Image d) PictureName

a) Custom b) Web
c) System d) User

a) System.Windows.Forms b) System.Form.Form

c) System.Form.Font d) System.Form.Control

a) Caption b) Data

c) Text d) Name

a) start b) run
c) break d) design

a) Lock Controls b) Anchor Controls
c) Lock d) Bind Controls

a) picture elements b) controls in the Toolbox
c) a set of fonts d) a set of colors on the Web tab
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Tutorial 3 Welcome Application 3

Figure 3.35 Calculator GUI.

a) Creating a new project. Create a new Windows Forms Application named
Calculator.

b) Renaming the Form file. Name the Form file Calculator.vb.

c) Manipulating the Form’s properties. Change the Text property of the Form to Cal-

culator. Change the Font property to 9pt Segoe UI. Change the Size property of
the Form to 272, 204. Note that Visual Studio resizes a Form when you change its font
size. Be sure to set the font size before setting the Form’s size.

d) Adding a TextBox to the Form. Add a TextBox control by double clicking it in the
Toolbox. A TextBox control is used to enter input into applications. Set the Text-

Box’s Text property in the Properties window to 0. Change the Size property to
240, 23. Set the TextAlign property to Right; this right aligns text displayed in the
TextBox. Finally, set the TextBox’s Location property to 8, 16—this property speci-
fies where the upper-left corner of the control is placed on the form.

e) Adding the first Panel to the Form. Panel controls are used to group other controls.
Double click the Panel icon ( ) in the Toolbox under the Container category
to add a Panel to the Form. Change the Panel’s BorderStyle property to Fixed3D

to make the inside of the Panel appear recessed. Change the Size property to 88,
112. Finally, set the Location property to 8, 48. This Panel contains the calculator’s
numeric keys.

Button

Panel

(contains 6 Buttons)

Panel

(contains 2 Buttons)

Decimal point Button

Subtraction Button
TextBox

Panel (contains 11 Buttons
for the numeric keys)
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f) Adding the second Panel to the Form. Click the Form. Double click the Panel icon in
the Toolbox to add another Panel to the Form. Change the Panel’s BorderStyle

property to Fixed3D. Change the Size property to 72, 112. Finally, set the Location

property to 112, 48. This Panel contains the calculator’s operator keys.

g) Adding the third (and last) Panel to the Form. Click the Form. Double click the
Panel icon in the Toolbox to add another Panel to the Form. Change the Panel’s
BorderStyle property to Fixed3D. Change the Size property to 48, 72. Finally, set
the Location property to 200, 48. This Panel contains the calculator’s C (clear) and
C/A (clear all) keys.

h) Adding Buttons to the Form. There are 20 Buttons on the calculator. To add a But-

ton to a Panel, double click the Button control ( ) in the Toolbox. Then
add the Button to the Panel by dragging and dropping it on the Panel. Change the
Text property of each Button to the calculator key it represents. The value you enter
in the Text property appears on the face of the Button. Finally, resize the Buttons,
using their Size properties. You can select more than one control and set their com-
mon properties (e.g., Size) at the same time. Each Button labeled 0–9, *, /, -, = and
. (decimal point) should have a size of 24, 24. The 00 and OFF Buttons have size 48,
24. The + Button is sized 24, 64. The C (clear) and C/A (clear all) Buttons are sized
38, 24. To align the numeric Buttons as they appear in Fig. 3.35, select the 1 Button

and set its Location property to 6, 6 and its Lock property to True. Place the 2 and 3
Buttons to the right of the 1 Button. Select the three Buttons in the top row (1, 2
and 3). Use the Format > Horizontal Spacing > Remove option to place the But-

tons directly next to each other. Use the Format > Align > Middles option to place
them in a straight row. Repeat the process to vertically align Buttons 1, 4, 7 and 0
using the Format > Vertical Spacing > Remove and Format > Align > Centers
options. You can drag and drop the rest of the numeric Buttons into position—the
IDE “snaps” each Button into alignment with those around it. The Format menu
contains many useful options. You can display many of the Format menu options in a
Visual Studio toolbar—right click the toolbar in the IDE and select Layout.

i) Saving and closing the project. Select File > Save All to save your changes. Then
select File > Close Project to close the project for this application.
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3.12 (Alarm Clock GUI) Create the GUI for the alarm clock in Fig. 3.36.

Figure 3.36 Alarm Clock GUI.

a) Creating a new project. Create a new Windows Forms Application named Alarm-

Clock.

b) Renaming the Form file. Name the Form file AlarmClock.vb.

c) Manipulating the Form’s properties. Change the Font property of the Form to 9pt
Segoe UI. Change the Text property to Alarm Clock. Change the Size property of
the Form to 276, 176. Remember to change the Font property’s size before you set
the Form’s Size property.

d) Adding Buttons to the Form. Add six Buttons to the Form. Change the Text prop-
erty of each Button to the appropriate text. Change the Size properties of the Hour,
Minute and Second Buttons to 60, 23. The ON and OFF Buttons get size 40, 23. The
Timer Button gets size 48, 32. Use the Format > Horizontal Spacing > Remove
option to align the Buttons in the top row as shown in Fig. 3.36.

e) Adding a Label to the Form. Add a Label to the Form. Change the Text property to
SNOOZE. Set its AutoSize property to False and its Size to 248, 23. Set the
Label’s TextAlign property to MiddleCenter. Finally, to draw a border around the
edge of the SNOOZE Label, change the BorderStyle property of the SNOOZE
Label to FixedSingle.

f) Adding a GroupBox to the Form. GroupBoxes are like Panels, except that GroupBoxes
can display a title. To add a GroupBox to the Form, double click the GroupBox control
( ) in the Toolbox. Change the Text property to AM/PM, and set the Size

property to 72, 72. To place the GroupBox in the correct location on the Form, set the
Location property to 104, 29.

Buttons

Label

RadioButton

GroupBox

© 2009 Pearson Education, Inc., Upper Saddle River, NJ. All Rights Reserved.
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g) Adding AM/PM RadioButtons to the GroupBox. Add two RadioButtons to the Form

by dragging the RadioButton control ( ) in the Toolbox and dropping it
onto the GroupBox twice. Change the Text property of one RadioButton to AM and
the other to PM. Then place the RadioButtons as shown in Fig. 3.36 by setting the
Location of the AM RadioButton to 16, 16 and that of the PM RadioButton to 16,
40. Set the AutoSize property to False and set their Size properties to 48, 24.

h) Adding the time Label to the Form. Add a Label to the Form and change its Text
property to 00:00:00. Change the BorderStyle property to Fixed3D and the Back-

Color to Black. Set the AutoSize property to False and set the Size property to
64, 23. Use the Font property to make the time bold. Change the ForeColor to
Silver (located in the Web tab) to make the time stand out against the black back-
ground. Set TextAlign to MiddleCenter to center the text in the Label. Position the
Label as shown in Fig. 3.36.

i) Saving and closing the project. Select File > Save All to save your changes. Then
select File > Close Project to close the project for this application.

3.13 (Microwave Oven GUI) Create the GUI for the microwave oven shown in Fig. 3.37.

Figure 3.37 Microwave Oven GUI.

a) Creating a new project. Create a new Windows Forms Application named
Microwave.

Buttons

Label

Panel

Panel (door)
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b) Renaming the Form file. Name the Form file Microwave.vb.

c) Manipulating the Form’s properties. Change the Form’s Font property to 9pt
Segoe UI and the Text property to Microwave Oven. Change the Size property to
552, 288.

d) Adding the microwave oven door. Add a Panel to the Form by double clicking the
Panel control ( ) in the Toolbox. Select the Panel and change the BackColor
property to Silver (located in the Web tab) in the Properties window. Then change
the Size to 328, 224. Next, change the BorderStyle property to FixedSingle. Posi-
tion the Panel as shown in Fig. 3.37.

e) Adding another Panel. Add another Panel and change its Size to 152, 224 and its
BorderStyle to FixedSingle. Place the Panel to the right of the door Panel, as
shown in Fig. 3.37.

f) Adding the microwave oven clock. Add a Label to the right Panel by clicking the
Label in the Toolbox once, then clicking once inside the right Panel. Change the
Label’s Text to 12:00, BorderStyle to FixedSingle, AutoSize to False and Size

to 120, 48. Change TextAlign to MiddleCenter. Place the clock as shown in
Fig. 3.37.
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g) Adding a keypad to the microwave oven. Place a Button in the right Panel by click-
ing the Button control in the Toolbox once, then clicking inside the Panel. Change
the Text to 1 and the Size to 24, 24. Repeat this process for nine more Buttons,
changing the Text property in each to the next number in the keypad. Then add the
Start and Clear Buttons, each of Size 64, 24. Don’t forget to set the Text properties
for each of these Buttons. Finally, arrange the Buttons as shown in Fig. 3.37. The 1
Button is located at 39, 80 and the Start Button is located at 8, 192.

h) Saving and closing the project. Select File > Save All to save your changes. Then
select File > Close Project to close the project for this application.

3.14 (Cell Phone GUI) Create the GUI for the cell phone shown in Fig. 3.38.

Figure 3.38 Cell Phone GUI.

Panel

Label
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a) Creating a new project. Create a new Windows Forms Application named Phone.

b) Renaming the Form file. Name the Form file Phone.vb.

c) Manipulating the Form’s properties. Change the Form’s Font property to 9pt
Segoe UI. Change the Text property to Phone and the Size to 184, 558.

d) Adding the display Label. Add a Label to the Form. Change its BackColor to Aqua

(in the Web tab palette), the Text to Welcome to Deitel Mobile Phone!, AutoSize
to False and the Size to 156, 210. Change the TextAlign property to MiddleCen-

ter. Then place the Label as shown in Fig. 3.38.

e) Adding the keypad Panel. Add a Panel to the Form. Change its BorderStyle prop-
erty to FixedSingle and its Size to 104, 136.
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f) Adding the keypad Buttons. Add the keypad Buttons to the Form (12 Buttons in
all). Each Button on the number pad should be of Size 24, 24 and should be placed
in the Panel. Change the Text property of each Button such that numbers 0–9, the
pound (#) and the star (*) keys are represented. Then add the final two Buttons such
that the Text property for one is Talk and for the other is End. Change the Size of
each Button to 20, 80, and notice how the small Size causes the Text to align verti-
cally.

g) Placing the controls. Arrange all the controls so that your GUI looks like Fig. 3.38.

h) Saving and closing the project. Select File > Save All to save your changes. Then
select File > Close Project to close the project for this application.

3.15 (Vending Machine GUI) Create the GUI for the vending machine in Fig. 3.39.
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Figure 3.39 Vending Machine GUI.

a) Creating a new project. Create a new Windows Forms Application named
VendingMachine.

b) Renaming the Form file. Name the Form file VendingMachine.vb.

c) Manipulating the Form’s properties. Set the Font property of the Form to 9pt
Segoe UI, the Text property to Vending Machine and the Size to 560, 488.

d) Adding the food-selection Panel. Add a Panel to the Form, and change its Size to
312, 344 and BorderStyle to Fixed3D. Add a PictureBox to the Panel, and change
its Size to 50, 50. Then set the Image property by clicking the Choose Image But-

ton and choosing a file from the C:\Examples\Tutorial03\ExerciseIm-

ages\VendingMachine directory. Repeat this process for 11 more PictureBoxes.

Label

GroupBox

Panel

PictureBoxes
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e) Adding Labels for each vending item. Add a Label under the first PictureBox.
Change the Text property of the Label to A1, the TextAlign property to Middle-

Center, AutoSize to False and Size to 50, 16. Place the Label so that it’s located as
in Fig. 3.39. Repeat this process for A2 through C4 (11 Labels).

f) Creating the vending machine door (as a Button). Add a Button to the Form by
dragging the Button control in the Toolbox and dropping it below the Panel.
Change the Button’s Text property to PUSH, its Font Size to 36 and its Size to 312,
70. Then place the Button on the Form as shown in Fig. 3.39.
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g) Adding the selection-display Label. Add a Label to the Form, and change the Text

property to B2, BorderStyle to FixedSingle, Font Size to 36, TextAlign to Mid-

dleCenter, AutoSize to False and Size to 160, 72.

h) Grouping the input Buttons. Add a GroupBox below the Label, and change the Text
property to Please make a selection and the Size to 160, 136.
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i) Adding the input Buttons. Finally, add Buttons to the GroupBox. For the seven But-

tons, change the Size property to 24, 24. Then change the Text property of the But-

tons such that each Button has one of the values A, B, C, 1, 2, 3 or 4, as shown in
Fig. 3.39. When you are done, move the controls on the Form so that they are aligned
as shown in the figure.

j) Saving and closing the project. Select File > Save All to save your changes. Then
select File > Close Project to close the project for this application.

Programming Challenge 3.16 (Radio GUI) Create the GUI for the radio in Fig. 3.40. [Note: All colors used in this
exercise are from the Web palette.] In this exercise, you create this GUI on your own. Feel
free to experiment with different control properties. For the image in the PictureBox, use
the file (MusicNote.gif) found in the C:\Examples\Tutorial03\ExerciseImages\Radio

directory.

▲
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Figure 3.40 Radio GUI.

a) Creating a new project. Create a new Windows Forms Application named Radio.

b) Renaming the Form file. Name the Form file Radio.vb.

c) Manipulating the Form’s properties. Change the Form’s Font property to 9pt Segoe
UI, the Text property to Radio and the Size to 576, 240. Set BackColor to Peach-

Puff.

d) Adding the Pre-set Stations GroupBox and Buttons. Add a GroupBox to the Form.
Set its Size to 232, 64, its Text to Pre-set Stations, its ForeColor to Black and
its BackColor to RosyBrown. Change its Font to bold. Finally, set its Location to 24,
16. Add six Buttons to the GroupBox. Set each BackColor to PeachPuff and each
Size to 24, 24. Change the Buttons’ Text properties to 1, 2, 3, 4, 5, 6, respectively.

e) Adding the Speakers GroupBox and CheckBoxes. Add a GroupBox to the Form. Set
its Size to 160, 64, its Text to Speakers and its ForeColor to Black. Set its Loca-
tion to 280, 16. Add two CheckBoxes to the Form. Set each CheckBox’s AutoSize
property to False and Size to 56, 24. Set the Text properties for the CheckBoxes to
Rear and Front.

PictureBox

ButtonCheckBoxes

TrackBar

GroupBox

GroupBoxes RadioButtons
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f) Adding the Power On/Off Button. Add a Button to the Form. Set its Text to Power

On/Off, its BackColor to RosyBrown, its ForeColor to Black and its Size to 72, 64.
Change its Font style to Bold.

g) Adding the Volume Control GroupBox, the Mute CheckBox and the Volume Track-
Bar. Add a GroupBox to the Form. Set its Text to Volume Control, its BackColor to
RosyBrown, its ForeColor to Black and its Size to 200, 80. Set its Font style to
Bold. Add a CheckBox to the GroupBox. Set its Text to Mute and its Size to 56, 24.
Add a TrackBar ( ) to the GroupBox.

h) Adding the Tuning GroupBox, the radio station Label and the AM/FM RadioBut-
tons. Add a GroupBox to the Form. Set its Text to Tuning, its ForeColor to Black

and its BackColor to RosyBrown. Set its Font style to Bold and its Size to 216, 80.
Add a Label to the GroupBox. Set its BackColor to PeachPuff, its BorderStyle to
FixedSingle, its TextAlign to MiddleCenter and its Size to 56, 24. Set its Text to
92.9. Place the Label as shown in Fig. 3.40. Add two RadioButtons to the GroupBox.
Change the BackColor to PeachPuff and change the Size to 45,24. Set one’s Text
to AM and the other’s Text to FM.

© 2009 Pearson Education, Inc., Upper Saddle River, NJ. All Rights Reserved.



Tutorial 3 Welcome Application 17

i) Adding the image. Add a PictureBox to the Form. Set its BackColor to PeachPuff,
its SizeMode to StretchImage and its Size to 56, 72. Set its Image property to
C:\Examples\Tutorial03\ExerciseImages\Radio\MusicNote.gif.

j) Saving and closing the project. Select File > Save All to save your changes. Then
select File > Close Project to close the project for this application.
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